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Pulser Description 

The Pulser device was developed to enable convenient visual programming of TTL pulse trains 
for pulsing LEDs, lasers and shutters used in Optogenetics experiments. The software enables 
the user to visually program trains of pulses, to create groups of trains and to add various 
triggering conditions as described in the following pages. The Pulser hardware unit is 
intended to be used with LED or laser light sources capable of fast switching by TTL pulses 
For general lab usage the Pulser hardware can be operated from LabVIEW, MATLAB, 
HyperTerminal and many other software packages. The software is compatible with windows 
XP, VISTA, Win.7, Win.8 and Win10. 

Health and Safety 

Prizmatix products are NOT authorized for use as components in life support devices or 
systems. 

The Pulser is intended for use as laboratory 
equipment only. 

It is not cleared or authorized for clinical 
use. 

 

Any maintenance should ONLY be performed by a technician authorized by Prizmatix.   

Important notice 

Prizmatix is a registered trademark of Prizmatix Ltd. 2007-2019. All rights reserved. 
All other product names or trademarks are property of their respective owners. 
Information in this manual is subject to change without notice and does not represent a 
commitment on the part of the vendor. The software described in this manual is furnished 
under a license agreement and may be used or copied only in accordance with the terms of 
the agreement. The material in this manual is copyrighted and may not be reproduced or 
electronically distributed without written permission from the copyright holder. 
Prizmatix Ltd. provides this publication "as is" without warranty of any kind, either express or 
implied, including but not limited to the implied warranties or conditions of merchantability 
or fitness for a particular purpose. In no event shall Prizmatix Ltd. be liable for any loss of 
profits, loss of business, loss of use or data, interruption of business, or for indirect, special, 
incidental, or consequential damages of any kind, even if Prizmatix Ltd. has been advised of 
the possibility of such damages arising from any defect or error in this publication or in the 
Pulser firmware or software. 
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Device Setup 

Remove the device from packaging and inspect for loose components or any signs of damage. 
Notify Prizmatix if the device appears damaged in any way: do not install a damaged device.  

Package Contents (Pulser or PulserPlus) 

Pulser PulserPlus  

  
USB-A to USB-B Cable BNC-BNC Cable 

  

Software Installation 

Please Download the most updated software from: 
www.prizmatix.com/software.htm 

 

 

 Item Description QTY 

1 Pulser or PulserPlus The USB-TTL Interface unit 1 

2 USB Cable 
USB Type-A to USB Type-B cable for 
connection of Pulser unit to PC 

1 

3 BNC-BNC Cable 
BNC-BNC cable for connection of the USB-
TTL Interface to Prizmatix LED controller 

1 

4 Software 
Please Download the most updated software 

from: www.prizmatix.com/software.htm 
1 
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Possible Pulser setups:  

(A) PC Control with direct connection to LED.  
Use this setup with Operation Mode (0). See Trigger Operation Modes section 
below 

(B) PC Control with external trigger device. 
Use this setup with Operation Mode (1), (2) and (3). See Trigger Operation 
Modes section below 
 

PulserPlus can be used in two additional setups: 
(C) PC Control with trigger in and trigger out to send pulses to additional triggered 

device. 
Use this setup with Operation Mode (0), (1), (2) and (3). See PulserPlus Tab and 
PC – Computer Operation Mode section below. 

(D) SA -Stand Alone mode, triggered or manually activated, no PC needed during 
operation 
Use this setup with Operation Mode (0), (1), (2) and (3). See PulserPlus Tab and 
AS – Stand Alone Operation Mode section below 
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Prizmatix 
 

7 | P a g e                                   Pulser User Manual  
 

Pulser System overview 

 

 
 

Pulser front panel: (1) – BNC connector for Trigger Input, (2) – BNC connector for TTL out 
signals. 

 

 

 
 

Pulser back panel: (1) USB connector for connection to computer, (2) – Device status 
indicator LED. 

 

 

Pulser General Specifications 

Maximum output current:  40mA 
Dimensions:    25 x 50 x 110 (W x H x L) 
Input Connector:  USB Type A 
TTL Output Connector: BNC (standard TTL levels) 
TTL Input Connector:  BNC (standard TTL levels) 
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PulserPlus System overview 

 
PulserPlus front panel: (1) – BNC connector for Trigger Input, (2) – BNC connector for TTL 

out signals, (3) – BNC connector for Trigger Output to external triggered device. 
 

 
 

PulserPlus back panel: (1) USB connector for connection to computer, (4) – Device status 
indicator LED, (2) – Operation mode selection switch, (5) – PC Computer operation mode 
indicator LED, (6) – SA Stand Alone operation mode indicator LED, (3) – Start button, (7) – 

Start indicator LED.  
 

PulserPlus General Specifications 

Maximum output current:  40mA 
Dimensions:    25 x 50 x 110 (W x H x L) 
Input Connector:  Standard USB Type A 
USB Adaptor for SA-Mode: 
Trigger In, TTL Output,  
Trigger Out Connectors: BNC (standard TTL levels) 
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Software Setup 

The Pulser system setup is performed in two steps: 

• Setup of Prizmatix Pulser PC software 

• Setup of Pulser device drivers 

Do not connect the Pulser device to the 
computer until the software setup process is 

complete 

Setup of Prizmatix Pulser PC Software 

Please download to a directory at your computer the most updated Pulser or PulserPlus 
software from: www.prizmatix.com/software.htm  
Run the setup.exe file and follow the instructions as they appear during the setup process 
and then re-boot the system to complete the software installation. 
Note: The setup will install NI-VISA (National Instruments' Virtual Instrument Software 
Architecture). Pulser PC software uses NI-VISA to communicate with the Pulser hardware 
via USB serial port. 

Device drivers for Pulser or PulserPlus 

The Device drivers used by Pulser (hardware version prior than 1.2U) and PulserPlus are 
different.  
The Device drivers used by Pulser (hardware version 1.2U and up) and PulserPlus are 
identical.  
If you have a Pulser device (hardware version prior than 1.2U), please follow installation 
instructions in Appendix D. Otherwise please follow installation instructions below. 

Setup of PulserPlus Device Drivers 

PulserPlus uses Virtual COM port (VCP) by FTDI (www.ftdichip.com) to communicate with 
the computer. VCP drivers cause the USB device to appear as an additional COM port 
available to the PC.  
After successful setup of the Prizmatix Pulser software, connect the Pulser to the computer 
with the supplied USB cable. If there is an available Internet connection, Windows will 
connect to the Windows Update website and install any suitable driver it finds for the 
device.  
 

http://www.prizmatix.com/software.htm
http://www.ftdichip.com/
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If the automatic installation takes place there is no need to continue with the procedure 
outlined below. 
 
In case you need to install the drivers manually, please download VCP drivers from: 
http://www.ftdichip.com/Drivers/VCP.htm  
Chose the correct file version from the table Currently Supported VCP Drivers and download 
the driver. The file name of the driver will be like: 
CDM v2.12.24 WHQL Certified.zip 
Extract the ZIP file to a directory, like: 
C:\Users\user\Downloads\CDM v2.12.24 WHQL Certified\ 

 
Press the Windows start button to bring up the start menu and select “Control Panel”. 
 
From the Control Panel window select Hardware and Sound and at the next screen select 
Device Manager. 
 
In the Device Manager window there will be a device under Other Devices with a yellow 
warning symbol to indicate a problem - no driver installed. The text next to this device will 
depend on the device attached. In PulserPlus case the name is FT232R device. 
 

 
 
 

http://www.ftdichip.com/Drivers/VCP.htm
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Right click on the other device (TTL232R in this example) to bring up a menu as shown 
below. 
 

 
 

 

From the displayed menu select “Update Driver Software…” This then displays the option 
for an automatic search or a manual search. 
 

 
 
Select the second option to browse manually. 
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In the address box put the exact location where the drivers have been saved to. This may be 
on a CD or in a folder on the PC. It is not necessarily the exact same location as shown in the 
screenshot. The drivers could have been saved anywhere of the users choosing.  
After entering the address select “NEXT” to start the installation. 
 

 
 
When the installation has finished a completion screen is displayed. 
 

 
 
Press Close to close this window and go back to the Device Manager Window. 
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The Device Manager will still show a device under Other Devices but in addition to this 
there is a new entry under Universal Serial Bus Controllers indicated in the screenshot 
above as the USB Serial Converter. This indicates the bus layer of the driver is installed. 
Installing the Virtual Com Port layer of the driver is almost a repeat of the last few steps. 
 
Right click on the other device (TTL232R in this example) to bring up a menu as shown 
below. 

 
 
From the displayed menu select “Update Driver Software…” This then displays the option 
for an automatic search or a manual search. 
Select the second option to browse manually. 
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In the address box put the exact location where the drivers have been saved to. This may be 
on a CD or in a folder on the PC. It is not necessarily the exact same location as shown in the 
screenshot. The drivers could have been saved anywhere of the users choosing.  
 

 
 
After entering the address select “NEXT” to start the installation. 
When the installation is finished a completion screen is displayed. 
 
Note this screen also displays the COM port assigned to the device. Press Close to close this 
window and go back to the Device Manager Window. 
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This time the Device Manager does not have a FT232R entry under Other Devices but does 
show entries under Universal Serial Bus Controllers and Ports (COM & LPT). The above 
screen shot displays a correct installation. The device is now ready to use on COM3.  
 
Note: Not all devices will install to COM3. The COM port allocation is determined by the 
installation wizard on the basis of the next free com port as designated in the PC registry 
 
Note: the full installation instructions can be found at 
AN_119_FTDI_Drivers_Installation_Guide_for_Windows7.pdf on www.ftdichip.com 
website. 
 
 

System Usage 

Connect Pulser or PulserPlus to the PC and check in the control panel the COM port 
assigned to the device. See above on finding COM port number by browsing Device 
Manager. 

Choose Pulser from Start menu to launch the Pulser software. 

 

The main Pulser screen will appear. Select the appropriate COM port from the list (28 in this 
example). If the appropriate COM port number does not appear at the list choose “Refresh” 
to allow the system to rescan available COM ports. When device is connected “Prizmatix 
PulserPlus is connected” message will appear at right bottom corner. While the search of 
the device you will notice “Please wait!” message. If device is not found the “No 
Connection” message will be displayed.  
 

 
 

http://www.ftdichip.com/
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Pulser software will automatically recognize the type of the Pulser device (Pulser or 
PulserPlus). The information is displayed at PulserPlus Setting tab by a check box. For initial 
use select PC-Computer from Operation Mode menu.  
 

 
 
The Pulser Windows software features a simple Graphical User Interface (GUI) for 
configuring multiple single or bi-phasic pulses in multiple trains. Go to the Train Setting tab 
to access these settings:  
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The trains set at Train Setting tab create a Group (a group of Trains). The Group properties 
can be viewed at Group Settings tab: 
 

 
 
For initial testing of the Pulser device, connect the Pulser TTL Out to TTL input connector on 
the Prizmatix LED Current Controller and set the following parameters: 
On PulserPlus Settings Tab: 

• Operation Mode: PC-Computer 

• Set all TrigOut parameters to zero (“0”) at this time 
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On Train Settings Tab: 

• Total # (numbers) of Trains (for example 10) 

• P1D – Pulse 1 Duration [msec] (for example 200) 

• P1I – Pulse 1 Interval [msec] (for example 200) 

• Select Operation Mode: (0) Execute pulse sequence after START 
 

 
 
On Group Settings Tab: 

• Set Total # (number) of Groups (for example 1)  
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Notes: 

• “Group Duration” is calculated from the values assigned at the “Train Setting” tab. 

• “Group Interval” field is not active since the current setting of “Total # of Groups” is 
1. If you change the “Total # of Groups” value to larger than 1 the “Group Interval” 
field will become active. 

• “Total Sequence Time” is calculated from the values assigned to all other fields. 
 

On the back panel of the device place the PC-SA switch into PC position. The small indicator 
LED near PC will turn to ON. The small green indicator LED light above USB connector will 
start to blink at about 1 Hz, indicating that the Pulser device is ready and awaiting 
instructions to be sent from the Prizmatix Pulser software. 
 
Press ”Start Sequence” button in the software window. The small green indicator LED light 
will stop blinking while the TTL Out will send the programmed pulses to the LED driver TTL 
input. When the pulse train is finished the green LED indicator will resume blinking at about 
1 Hz. 
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Software Menu 

The Pulser software features File, Options and Help menus. 
 

 
 
File>Open Settings 
Enables user to open a saved settings file. See next menus. 
File>Save Settings 
Enables user to save current Pulser / PulserPlus settings into predefined file. See next menu. 
File>Save Settings As… 
Displays a dialog box enabling the user to save current Pulser / PulserPlus settings into a 
new file. This option enables multiple user to share the Pulser device in a convenient way.  
File>Exit 
Exit the Pulser software. The software saves the setting before exiting. 
 
Options>Open Log File 
Enables user to open currently used Log file. See next menus. 
Options>Enable Log 
Enables the logging of Pulser activity into predefined file. When Logging is enabled a check-
mark will appear near the Enable Log menu. 
Options>Define Log Filename… 
Enabling the user to choose new Log file name.  
Don’t forget to check the Enable Log menu to activate the Logging. 
Options>Create Command String… 
Enabling the user to create Command String to call Pulser hardware from other software 
such as Noldus EthoVision® XT.  
Options>Update Firmware 
Displays a dialog box enabling a user to update the Pulser microcontroller firmware. Please 
don’t use this menu unless you received explicit instructions from the Prizmatix technical 
team. 
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Help> User Manual… 
Displays the user manual PDF file. 
Help> Prizmatix Website… 
Opens the Prizmatix website (www.prizmatix.com) at default browser. 
Help> About Pulser… 
Displays a dialog box with information. 
 

Trigger Operation Modes 

Prizmatix Pulser enables the user to choose one of five Operation Modes related to TrigIn 
(Trigger In): 

(0) Execute pulse sequence after START 
(1) Execute pulse sequence once after trigger(s) 
(2) Execute pulse sequence each time after trigger(s) 
(3) Execute pulse sequence after trigger HIGH, then stop when LOW 
(4) Execute pulse sequence after trigger LOW, then stop when HIGH 

 

 
 

Note: The discussion of Operation Modes is relevant to both Pulser and PulserPlus devices.  

Mode (0): Execute pulse sequence after START 

In this mode the sequence will not depend on the trigger input state. The pulse sequence 
will start after clicking on “Start” button in the software window.  
The small indicator LED light on Pulser device will blink at about 1 Hz while waiting for the 
click on “Start” button. During the pulse train the small LED indicator will stop blinking. 
To terminate operation mode (0) press “STOP” button on the Pulser PC software. 

Mode (1): Execute pulse sequence once after trigger(s) 

In this mode the user connects the TTL trigger cable from the triggering device to the 
“Trigger In” BNC connector. After clicking the software “Start” button, the green LED 
indicator will start blinking at a rapid rate (about 10 Hz) indicating that the Pulser is waiting 
for a "Trigger In" signal. When “Trigger In” receives TTL High, the green indicator LED will 
stop blinking and the TTL Out will send the programmed pulses to the LED driver TTL input. 
When the pulse train will be finished the green LED indicator will resume blinking at about 1 
Hz. Additional TTL High signal at “Trigger In” will not restart the pulse sequence until the 
user will click the software “Start” button and “Trigger In” will receive TTL High signal. 

http://www.prizmatix.com/
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To terminate operation mode (1) press “STOP” button on the Pulser PC software. 
User can specify number of triggers the “Trigger In” should receive to start the sequence of 
programmed pulses at “TTL Out” 
 

 

Mode (2): Execute pulse sequence each time after trigger(s) 

Connect the TTL trigger cable from the triggering device to the “Trigger In” BNC connector. 
After clicking on the software “Start” button, the green LED indicator will start blinking at a 
rapid rate (about 10 Hz) indicating that the Pulser is waiting for a “Trigger In” signal. When 
the “Trigger In” receives TTL High, the green LED indicator will stop blinking while the TTL 
Out will send the programmed pulses to the LED driver TTL input. When the pulse train is 
finished the green LED indicator will resume blinking at about 1 Hz. An additional TTL High 
signal at "Trigger In" will re-initialize the programmed pulse sequence.  
To terminate operation mode (2) press “STOP” button on the Pulser PC software. 
User can specify number of triggers the “Trigger In” should receive to start the sequence of 
programmed pulses at “TTL Out” 

Mode (3): Execute pulse sequence after trigger HIGH, then stop when LOW 

Connect the TTL trigger cable from the triggering device to the “Trigger In” BNC connector. 
After clicking on the software “Start” button the green LED indicator will turn OFF until 
“Trigger In” receives TTL High. When Trigger In will receive TTL High level, the Pulser will 
generate the user defined pulse sequence until the "Trigger In" will return to TTL Low level. 
During generation of the pulse sequence the LED indicator will be continuously ON.  
To terminate operation mode (3) press “STOP” button on the Pulser PC software.  
Remark (PulserPlus only): if Trigger Out was set, it will start after completion of the TTL 
pulse sequence (when “Trigger In” will go to Low).  
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Mode (4): Execute pulse sequence after trigger LOW, then stop when HIGH 

Same as Mode (3) but “Trigger In” waits for TTL Low to start generation of the user defined 
pulse sequence. The TTL High will stop the pulse sequence.  
Remark (PulserPlus only): if Trigger Out was set, it will start after completion of the TTL 
pulse sequence (when “Trigger In” will go to High).  

Trigger Out Settings 

PulserPlus device enables triggering or various external devices after completion of the TTL 
pulse sequence. Use TrigOut BNC on the PulserPlus device front panel to connect external 
device TTL input (0Volt – LOW, 5Volt HIGH).  
On PulserPlus Settings Tab: 

• TrigOut Delay After Sequence Finish [ms] (for example 10) 

• TrigOut Duration [ms] (for example 2000) 

• TrigOut interval [ms] (for example 2000) 

• Number of TrigOut Pulses (for example 3) 
The TrigOut can work in both PC-Computer mode as well as in SA – Stand Alone Mode, see 
below. 
 

 

 

Stand Alone Mode 

SA – Stand Alone Mode available only for PulserPlus device. In SA-Mode PulserPlus device 
can operate without computer while the power supplied to the device from a general 
purpose small USB power adaptor (like wall plugged devices used for cellular phones 
recharging). The PulserPlus will start the pre-programmed sequence after user will press the 
Start button (PC-SA switch on the back panel shall be in SA position).  
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To program the Pulser from PC software chose the SA – Stand Alone Prog. from Operation 
Mode dropdown menu at PulserPlus Setting tab and place the PC-SA switch at PC position 
during programming. 
 
 

 
 
Note that due to change of Operation Mode to SA – Sand Alone Prog. the “Start Sequence” 
button was renamed to “Start Programming”. 
After pressing “Start Programming” (PC-SA switch shall be at PC position during 
programming) following dialog box will appear: 
 

 
 

Now in order to use the device in Stand Alone (SA) mode, change the PC-SA switch to SA 
position and press Start button on the PulserPlus device.  
Note: PulserPlus cannot be programmed when PC-SA switch is set to SA or OFF positions 
but ONLY at PC mode. 
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How to Call Pulser Hardware from Other Software 

The Pulser or PulserPlus can be used with MATLAB, LabVIEW and any HyperTerminal-like 
software capable of sending and receiving simple ASCII commands over a USB interface. 
In order to send commands to the Pulser the COM port should be configured with following 
settings:  

Bits per second: 57600 
Data bits: 8 
Parity: None 
Stop Bits: 1 
Flow Control: None 

 

The setting can be changed at Device Manager (see Pages 9 and 12). Right Click the 
Prizmatix DRV device and select Properties from the list: 
 

 
 

The COM Port settings can be configured at the Port Settings tab: 
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The Pulser or PulserPlus device can accept commands send to the serial COM port. See 
below how to create Command String easily from Options nemu. 
The Command String has following format: 
MTNT,BI,P1D,P1I,P2D,P2I,TNG,GI,OM,NoT,ToDy,ToDu,ToIt,ToNu@ 

Where 
M – Command prefix. No comma (“,”) between “M” and next data 
TNT – Total # of Trains [1, 2…] 

TI – Train Interval [msec] 
P1D – Pulse 1 Duration [msec] 
P1I – Pulse 1 Interval [msec] 
P2D – Pulse 2 Duration [msec] 

P2I – Pulse 2 Interval [msec] 

TNG – Total # of Groups 
GI – Group Interval [sec] 
OM – Operation mode     

for Pulser: 
chose one of 0 or 1 or 2 or 3 or 4  
(for definition see section Trigger Operation Modes at page 21) 

for PulserPlus in PC – Computer mode:  
the values for OM are: 100≤OM≤104 
chose one of 100 or 101 or 102 or 103 or 104 
(Mode 100 correspond to Mode 0 of Pulser, 
Mode 101 correspond to Mode 1 of Pulser etc..)  

for PulserPlus in SA – Stand Alone Prog. Mode: 
the values for OM are: 110≤OM≤114  
chose one of 110 or 111 or 112 or 113 or 104 
(Mode 110 correspond to Mode 0 of Pulser, 
Mode 111 correspond to Mode 1 of Pulser etc..)  

NoT – Number of TrigIn [1, 2…] 

ToDy  – TrigOut Delay from last Train finish [msec] 
ToDu – TrigOut Duration [msec] 
ToIt – TrigOut Interval [msec] 
ToNu - Total Number of TrigOut [0,1,2...] 

@ - character “@” indicate end of command. 
 
Notes:  

• No comma “,”  is needed after "M" character – the prefix 

• No comma “,”  is needed before "@" character – the suffix 

• All sent numbers should be integers (whole numbers)  

• At the end of a string there's no need to send “End of Line”, “Carriage Return” or any 
other termination character 
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Examples: 
Example of command for Pulser   
M TNT, TI, P1D, P1I, P2D, P2I, TNG, GI, OM, NoT@ 

M 10 , 0 , 200, 200, 0  , 0  , 1  , 0 , 0 , 1  @ 

Use without spaces like: 
M10,0,200,200,0,0,1,0,0,1@ 
Example of command for PulserPlus PC – Computer mode   
M TNT, TI, P1D, P1I, P2D, P2I, TNG, GI, OM, NoT, ToDy, ToDu, ToIt, ToNu@ 

M 10 , 0 , 200, 200, 0  , 0  , 1  , 0 , 100, 1 , 1000, 200 , 200 , 5   @ 

Use without spaces like: 
M10,0,200,200,0,0,1,0,100,1,1000,200,200,5@ 
 
Example of command for PulserPlus SA – Stand Alone Programming mode   
M TNT, TI, P1D, P1I, P2D, P2I, TNG, GI, OM, NoT, ToDy, ToDu, ToIt, ToNu@ 

M 10 , 0 , 200, 200, 0  , 0  , 1  , 0 , 110, 1 , 1000, 200 , 200 , 5   @ 

Use without spaces like: 
M10,0,200,200,0,0,1,0,110,1,1000,200,200,5@ 
The sequence will start after user will change the switch PC-SA to SA and press Start button 
on the back panel of PulserPlus device. 
 
While working at operation modes (0) or (1) after the Pulser will finish an operation it will 
send a Finish command to the PC: 
F     (Capital F) 
 
If Pulser is operated in operation mode (2) or (3) it will not send a Finish command as it 
always waits for new trigger(s). The execution of operation mode (2) or (3) can be 
terminated by Stop command as described below. 
 
The Pulser can accept a Stop command to terminate an operation. The Stop command can 
be sent to the Pulser in operation modes (0) - (3). The  Stop command format is:  
S EOL   (Capital S followed by End of Line) 
After the Pulser will terminate an operation it will send to the PC: 
A     (Capital A) 
 
When PulserPlus SA – Stand Alone Prog. Mode and programming command includes 
operation mode 110≤OM≤114, PulserPlus will send receive confirmation to the PC: 
R  (Capital R) 
 
Command String Generator 
Pulser Windows software enables user to create the Command String from Options menu. 
Follow these steps to create the Command String: 

a) Connect the Pulser or PulserPlus device to the PC. 
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b) In case of PulserPlus move the Operation Mode Selection switch (PC-OFF-SA) to PC 
position. 

c) Select correct COM Port and wait until the software will synchronize with the Pulser 
Device. At bottom-right corner a blue message will appear 

d) Set the Operation Mode, Pulse Sequence and all other required parameters 
e) Select Create Command String from Options menu. 
f) Following dialog will appear: 

 

 
 

g) Select the Command String (click inside the dialog box, press Ctrl+A, Ctrl+C) 
h) Click inside the target software and paste the Command String (press Ctrl+V). 
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Appendix A: Setup of Pulser Device Drivers on Win. XP PC System 

In order to setup the Pulser Device Drivers on Windows XP system please start the setup 
procedure according to section “Setup of Pulser Device Drivers” above up to a  referral to 
Appendix A. and proceed from here: 
The Hardware Update Wizard window will appear: 
 

 
 

Choose “No, not this time” and click “Next”. At the next screen choose “Install from a list or 
specific location” and click “Next”. 
 

 
On the next screen choose “Include this location in the search” and browse My Computer 
for driver software at: 

C:\Program Files\Prizmatix Pulser\Drivers and click on Next. 
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A new window will appear: 

 

Immediately followed by another window, click “Continue Anyway”: 

 

After few seconds the procedure will be completed and a final window appear: 
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Click on “Finish” to complete the setup. 

Once the driver installation is complete the Pulser software can be used. 

 

Appendix B: Known Software Issues 

Error 8 

Problem: After pressing EXIT button you receive an Error Message Box: “Error 8 occurred at 
Open/Create/Replace File…”.  
Solution: The problem is due a file-save permissions issue. It occurs during EXIT when Pulser 
software tries to save the current software configuration into a file.  
We need to change the Privilege Level of the Pulser.EXE file: 
Press Start button, Right click the Pulser and select Properties from the drop-down menu 
 

 

Click on Open File Location button to view the Pulser.exe file in the folder.  
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Right click the Pulser.exe file and select Properties from the drop-down menu 

 
 

On Compatibility Tab of Properties dialog box click on Change Setting for all users check 
"Run this program as an Administrator" and press OK on both dialog boxes: 
 

 
 

From now the Pulser.exe will have permission to save configuration files and the Error 
message will not appear again. 
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Appendix C: Updating Pulser Firmware 

 

Don’t perform Firmware Update unless you received explicit  
Instructions from the Prizmatix technical team. 

 

Open the Update Firmware dialog by selecting Options >Update Firmware from Pulser 
software menu. 
 

 
 

1) Select the correct COM Port (COM18 in this example). See section “Setup of Pulser 
Device Drivers” in this manual for details how to find the Pulser COM port. 
 

2) Click “Select Firmware Updating File (*.hex)” button and browse to  
C:\Program Files (x86)\Prizmatix Pulser 2.3\Firmware\ 
Pulser_05_2.cpp.hex 
or other appropriate  *.hex  file. 

3) Click “Start Update” button to begin update. 
 

When the update is completed successfully the following dialog box will appear: 
 

 
 

Click “Close”. 
Your Pulser is now updated with the latest firmware and ready to go. 
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Appendix D: Setup of Pulser Device Drivers 

After successful setup of the Prizmatix Pulser software, connect the Pulser to the computer 
with the supplied USB cable.  
Windows will begin the standard driver installation procedure and after a few moments the 
process will fail.  
Click on the Start Menu, and open up Control Panel 
Navigate to System and Security. Next, click on System. Once the System window is up, 
open the Device Manager. 
An alternative way to get to device manager is to right-click on the “My Computer” icon on 
the desktop and choose “Manage” from the menu. 

 

Choose Device Manager on the left panel and look for “?” unknown device in the list in the 
right panel. 
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Right click on the unknown device and choose the "Update Driver Software" option. 
 

 
 
From now will be some difference between Win XP and Win VISTA/7/8 systems.. For 
installation on Win XP see Appendix A 
The Update Driver Software dialog will appear: 

 

Choose “Browse my computer…” 
 
On next screen in section “Search for driver software in this location” Browse my computer 
to driver software: 

C:\Program Files (x86)\Prizmatix Pulser\Drivers and click on Next. 
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A new window will appear, immediately followed by a window of Windows Security. Click 
“Install” 

 
 
After few moments the installation will be completed and a dialog box will appear: 
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Note the COM port number displayed at the top of the dialog box (COM18 in this example). 
Click on “Close” to complete the setup. 

Now open the Device Manager. The Prizmatix Pulser device will be found in the list in the 
right panel. Please notice the COM port number (18 in this example). 

 
 
Once the driver installation is complete the Pulser software can be used 
 


